Trema-edgeのインストールと設定

提供:TuntunkunMediaWiki

移動: 案内, 検索

目次

Trema-edgeとは

Trema-edgeはOpenFlow1.3に対応したOpenFlowコントローラでNECによって開発が行われています。

必要なパッケージのインストール

Treama-edgeをインストールするためにはruby2.0のインストールが必要です。まずは、ruby2.0をインストールする際に使用するrvmのインストールに必要なパッケージのインストールを行います。

sudo apt-get install curl

rvmのインストール

何の設定も行わなかった場合には、ホームディレクトリにインストールされます。

curl -L https://get.rvm.io | bash

RVMのアクティベート(一時的にruby2.0のインストールが終わると.bash_profileに自動的に書き込まれる)

source ~/.rvm/scripts/rvm
rvm get head
rvm reload
rvm install ruby-2.0.0-p247
rvm use 2.0.0

Trema-edgeのインストール

$git clone git://github.com/trema/trema-edge
$cd trema-edge
$bundle install
$rake
個人用ツール
名前空間
変種
操作
案内
ツールボックス